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Batch Processing 

Batch processing options are used to update frequently modified information such as 

performance reviews, events, and attendance history in “batches” rather than one record at a 

time. Entering a batch of changes with one process with all fields collected on one screen is 

far faster than retrieving a record and making changes one by one. 

The process is simple. Most batches are entered in a grid. Each row in the grid represents a 

single change to a performance review, event, attendance history, etc. You can select the 

appropriate employee or applicant from the grid and then complete the remaining fields on 

the row. When one row is complete, you can complete the next row and so on. When all of 

the desired rows have been entered, the entire batch can be posted using the Post Batch 

option. The changes are updated to the database immediately and an audit trail of the changes 

can be produced. 

As the changes are updated to the database, the existing records are pushed down (record one 

becomes record two, record two becomes record three, etc.) so that the first record is blank. 

The entry coming from the batch processing option is then added as a new record one. Thus, 

no existing data is lost via this process and the standard sort that places newest records on top 

is preserved. 

When entering a batch, it is possible to enter multiple entries for the same record. During 

processing, each entry is treated individually and thus if there are multiple entries, the process 

described above is simply repeated for each entry. For example, if you were entering 

attendance history and an employee had both a sick day and a vacation, you could make two 

entries in the batch. Both entries would be posted just as if they had been entered in totally 

different batches. 

Batch processing processes utilize one of two different types of screens: grid style and combo 

style. A sample of each is shown below. 

Grid Style 
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Grid style screens are normally used when a complete record can be entered on a single line 

in the grid. For example, a complete performance review can be entered as shown in the 

sample above.  

Combo Style 

 

Combo style screens are normally used when a collection of information is to be entered once 

and then a group of records is to be specified. For example, if a number of employees took 

the same training course, you would not wish to key the course information over and over 

again. With a combo style batch processing screen, you key the course information using text 

boxes and check boxes, and then use a simple grid to select the employees to be updated, as 

shown in the sample above. When the batch is posted, the records are updated one by one. 

Each record that is posted uses the same information from the text boxes and check boxes 

that have been completed. 

Standard Data Entry Conventions 

The fields used in batch processing screens reflect the same characteristics and attributes that 

the fields possess on the normal data entry screens. For example, on a batch processing screen 

used to post training records, the training code and related fields act exactly like the training 

code field on the Training History screen. If the field is supported by a table on the Training 

History screen, the field is supported by a table in the batch processing screen. 

Lookup for Batches 

All batch-processing screens provide a means of selecting the records to be processed. In 

simple grid style screens and in the record grid of a combo style screen, the first field is the 

ID field for the module and the second field is either a name or a description that is used to 

describe the record. You can select a record using either the ID or the name column by 

entering a full or partial ID or a full or partial name. If the ID or name entered is a direct 

match for a single record, the ID and name fields are completed and the cursor is positioned 

to the third column. If the ID or name entered matches multiple records, the Select Employee 

screen is displayed. 



Workbook 

 

 Batch Processing     3 

 

The screen contains a list of the records that match the criteria entered. You can select from 

these records by scrolling to the desired record and highlighting it. Then, double-click or 

click the OK button. 

Pre-Populating a Batch 

Batch processing screens are normally populated one record at a time as described above. 

However, you can populate the ID and name for a group of records using the Lookup Group 

option on the File menu. The Lookup Group option activates the same Lookup screen that is 

used to select records for data entry and returns all of the records that meet the Lookup 

criteria. You can use all five tabs on the Lookup screen including any favorites you have 

defined for the Favorites tab. 

This method is especially useful with combo style screens. You can define the fields to be 

updated and then select all of the applicable records with one lookup. For example, if you 

were using the a combo style screen for the purpose of batching in training records for a 

department that attended the same training course, you could record the training course detail 

and then select all of the employees who received that training using a simple query on the 

Lookup screen. This would be far faster than selecting the individual employees one at a 

time. 

If you use this feature with grid style screens, the first columns are filled with the ID and 

names for the records selected. You must then complete the remaining fields on each line. 

This technique can still be very beneficial because the list of names becomes a checklist. You 

know the batch has been entered when you have completed the data entry for each name 

displayed. For example, if you needed to perform attendance batch processing for every 

employee in a specific department, you could use the Lookup screen to select those records. 

Once the records have been returned in a list, you could then enter the remaining fields for 

each record to complete the process. If you had created a lookup favorite for each department, 

this would make the process even more efficient. 

Posting a Batch 

When a batch has been entered, it can be posted using the Post Batch button on the Tool Bar 

or the Post Batch option on the File menu. The changes are updated to the database 

immediately and an audit trail of the changes can be produced. A sample from a batch audit 

trail is shown below. 

 

As the changes are updated to the database, the existing records are pushed down (record one 

becomes record two, record two becomes record three, etc.) so that the first record is blank. 

The entry coming from the batch processing option is then added as a new record one. Thus, 

no existing data is lost via this process and the standard sort that places newest records on top 

is preserved. 

As records are posted, they are updated with an ‘X’ in the last column of the grid to show 

they were posted. Records that are posted will not be posted again if they are part of a 
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partially posted batch. If all the records in a batch are posted, all of the entries in the batch are 

set to display only and the status of the batch is set to ‘Posted’. 

Records That Are In Use 
If a record selected for batch processing is in use at the time the batch is posted, the record is 

not posted, it is not included on the audit trail, and it is not marked as posted. If a batch has 

unposted records, a message will be displayed indicating that the remaining records could not 

be posted. You have three choices for the unposted records; you can: 

1. Delete the records from the batch and add the records to another batch at a later time,  

2. Contact other users and ask them to exit the records in use so that you can try posting 

again, or 

3. Save the batch and attempt to post the records at a later time. 

Postponing a Batch 

Batches that have been started and have not been posted can be postponed for posting at a 

later date. This is useful when you are entering batches for specific groups. If you do not wish 

to post a partial group, but must perform another task, you can postpone the batch and return 

to it later when you have more time. In addition, when you post batches, records that are in 

use when you attempt to post are left in the batch and are not posted. One of your options is 

to postpone the pending records and try to post them later.  

To postpone that batch until later, all you have to do is save your changes. Saving a batch is 

just like saving a record or a document. If you want to save the batch and work on another, 

you would simply use the Save option on the File menu or Tool Bar, and then create a new 

one or select another from the list. If you want to leave the batch process altogether, use the 

Exit option, which saves and closes the screen, or click the ‘X’ in the upper right-hand corner 

of the screen and say ‘Yes’ to save the changes. 

Recalling a Postponed Batch 
If you have previously postponed a batch, you can recall it by selecting it from the list of 

batches in the Batch List area. That batch’s entries are displayed in the grid below. You can 

now pick up where you left off. You can post the batch immediately or you can add records 

to the batch.  

Note: Only users with Administrator access (Administrator check box selected in Security 

Setup) have access to all user batches. This allows them to process a batch in a user’s 

absence. Non-Administrator users only have access to the batches they created.  
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Batch Processes  

The following are batch processes available within Essential HR. 

Event Batch: Used to post status events to the corresponding fields on the Event History sub 

screen that is located on the Status screen in the employee record.  

Performance Batch: Used to post results of completed Performance Reviews to the 

Performance Reviews screen.  

Salary Batch by Employee: Used to post a salary update for multiple employees without 

having to navigate through individual records. The changes will be posted to the 

Compensation History grid and will update the Current Pay frame in the Compensation 

History screen.  

Salary Batch by Rate: Used to post a salary update for a group of employees who share the 

same rate change.  

Other Compensation Batch: Used to post compensation received by the employee that is 

not associated with base pay to an employee record. This includes bonuses, commissions, and 

any other type of alternate pay.  

Training Batch by Employee: Used to post completed training courses and their details to 

the Training/ Competency screen in an employee’s record.  

Training Batch by Course: Used to post completed training courses for a group of 

employees who completed the same training course to the Training/ Competency screen in an 

employee’s record.  

Medical Exam Batch: Used to post completed medical exam details to the Medical Exam 

grid on the Medical/ Wellness sub screen.  

Claim Cost Batch: Used to post claim costs related to an incident and their details to the 

Cost Details sub screen in an incident record.  

Payment Batch: Used to post COBRA payments related to an incident and their details to 

the Payment History grid on the Personal screen.  

 

  



Workbook 

 

6     Batch Processing 
 

Notes 
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This lesson describes the techniques used to load and post batches. It also shows how to 

postpone a batch that cannot be completed and recall that batch at a later time. 

Tutorials 
Loading a Batch: demonstrates how much faster batch processing can be than manually 

entering records. It also shows how the operating conventions for batch processing screens 

are the same as those in other screens. 

Posting a Batch: shows how to post a batch and print the audit trail. It also shows how to 

confirm that a batch entry has been posted. 

Postponing and Recalling a Batch: demonstrates how to postpone a batch in process and 

recall that batch at a later time  
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Tutorial 1.1 – Loading a Batch 

Before we see how to load a batch, let’s demonstrate how Performance Appraisals are keyed 

without using batch processing. 

1. Start People-Trak by double-clicking on the People-Trak Trainee icon on your desktop 

(or as instructed).  

 

The Select Product Option screen is displayed.  

2. The Position Control and Attendance options should be the only options that are 

toggled on. If not select the Training button to select them. 

3. Click OK 

 

The Login screen is displayed. 

4. In the User ID field, enter DEMO. 

5. In the Password field, enter DEMO. 

 

The Organizer desktop is displayed with the Personnel Management module selected.  

6. Open Donald Stern’s record. 

7. Move to the Performance screen.  

8. On the Tool Bar, click the Insert Row button to insert a new row for Donald’s latest 

appraisal.  

9. Enter the appraisal as shown below: 

 

Initiation Date  Today’s Date  

Completion Date  Today’s Date 

Appraisal Type Annual (the Next Date and Next Type fields are set for you)  

Appraiser Type Manager 

Appraiser  Rhoda E. Tyrell 

Rating   Leave Blank 

10. Close the record, saving your changes.  

11. Now select two other records and record the same appraisal, saving your changes. 

12. Close any open record. 

 

Now, we will learn how to use batch processing to do the same thing.  

13. On the Processing menu, select Performance Batch.  

 

The Performance Batch screen is displayed. This is an example of a grid style batch 

processing screen. Grid style screens are normally used when a complete record can be 

entered on a single line in the grid, which is the case here. 

 

Let’s create a new batch. 
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14. On the File menu, select New Batch or on the Tool Bar, click the New Batch button to 

create a new batch. 

 

A new batch is created with a Status of In Process and placed in the Batch List area at 

that top of the screen. The batch name assigned is your user name followed by a dash and 

a sequence number. You can rename this batch if you choose. If you don’t plan on 

keeping the batch after posting, it really doesn’t matter. 

 

Let’s demonstrate how to rename a batch in case you do decide you want to do this. 

15. On the File menu, select Rename Batch. 

 

The Rename Batch is displayed.  

16. In the New Name field, enter My Batch, and click Rename. 

 

The name of the batch is changed to this new name. 

 

Now, let’s create some entries in this batch. 

17. In the Employee ID column, enter a 1 and press ENTER.  

 

A list of those employees with employee numbers that start with 1 are displayed.  

18. Select the record for Donald Stern.  

 

The Employee ID and the Full Name are returned to the first two columns. 

19. On the Tool Bar, click the Delete Row button to delete this entry.  

20. Now, enter the complete employee number 1006 in the Employee ID field and press 

ENTER.  

 

Because 1006 is a direct match for Donald Stern, the Employee ID and Full Name are 

returned. 

21. Delete the row again. 

 

Let’s try something else. You can select employees by either number or name.  

22. To select an employee by name, click in Full Name column and enter the letter S.  

 

When you press ENTER, you will be presented with a list of all employees with a last 

name starting with S.  

23. Select Donald Stern.  

 

Again, the Employee ID and Full Name are returned to the first two columns. 

24. Finally, clear the row one last time.  

25. Now select Donald Stern by keying a complete last name in the Full Name column. 

 

When the Employee ID and Full Name are displayed for the fourth time, you will have 

demonstrated for yourself that you can select an employee for a batch using a full or 
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partial name or number. Now we can continue with the batch. 

 

The Initiation Date and Completion Date fields, as with all fields in Batch Processing, 

shares the same attributes as the corresponding field on the data entry screen. Thus, you 

can enter the date using standard operating conventions. These include keying the date by 

hand, using the calendar popup button, or using the Date Stamp feature.  

26. For the Initiation Date, enter a date a few days ago. 

 

The Date Stamp feature is very useful in Batch Processing because you frequently key 

records with the same date. For example, the completion dates of this batch might all be 

the same and might be today’s date. Let’s use the date stamp this time. 

27. In the Completion Date field, use the Date Stamp feature by clicking the Date Stamp 

button on the Tool Bar or pressing F4. 

 

Today’s date is automatically entered for you. 

28. In the Appraisal Type field, use the popup button to select the Annual appraisal.  

 

Note that the Appraisal Next Date and Appraisal Next Type fields are automatically set 

based on the entries in the table.  

29. Complete the rest of the appraisal just as you did earlier on the Performance Appraisals 

screen. 

30. Continue with the next tutorial. 
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Tutorial 1.2 – Posting a Batch 

Let’s finish the batch we started in the last tutorial and then post it. We’ll learn something 

new on the way. 

1. On the Edit menu, select Set Date Stamp. 

 

The Select Date screen is displayed. This allows you to change the date to use for the date 

stamp feature. 

2. Click on yesterday’s date and then click OK. 

3. Now, add another entry for an employee. In the Completion Date field, press F4. 

 

The date that you assigned the date stamp (yesterday’s date) is returned.  

4. Finish that entry and add one more entry for another employee.  

5. On the File menu, select Post Batch or click the Post Batch button on the Tool Bar to 

post the batch.  

 

The following message is displayed: 

Post this Batch? 

6. Click Yes to post the batch.    

 

When the batch has been posted, an audit trail is created and displayed in the Document 

Viewer. The audit trail is a history of the work you have just performed. When you create 

real batches, you may wish to print and file the batch or use it to compare against the 

original source documents to confirm that all entries were entered and posted.  

7. For now, just exit the Document Viewer. 

 

When you leave the Document Viewer, the Performance Batch screen is displayed. The 

Status for that batch in the Batch List area is now Posted. The entries in the grid are now 

display only and have an X in the last column to signify that they were indeed posted. 

You can create another batch or you can exit the batch and perform another task. 

 

If records could not be posted for some reason, the records that could not be posted will 

appear in the audit trail with No in the last ‘X’ column. They will also not have that 

column flagged with an ‘X’ on the screen when you return. Those non-posted entries can 

be updated. You can try to post the records again or you can postpone the batch. When 

the batch is posted again, only the non-posted entries will be processed and posted, if 

possible.  

 

Note: The most common reason why a record will not post is that another user is 

currently editing that record. 

8. Exit the batch. 

9. Open Donald Stern’s record.  

10. Move to the Performance Appraisals screen. 
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Note that the appraisal that you “batch entered” is now the first record on the screen and 

that all other records have been pushed down. This is the way that all batch processes 

work. The new entries are always added at the top. 

11. Close Donald’s record. 

12. Continue with the next tutorial 
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Tutorial 1.3 – Postponing and Recalling a Batch 

There are times you may need to postpone a batch and then work on it later. This tutorial will 

show you how to postpone a batch and then recall it. 

1. On the Processing menu, select Performance Batch.  

2. Using what you have learned in this lesson, enter a three-employee batch of Performance 

Appraisal.  

3. Use the Rename Batch feature and name the batch My Postponed. 

 

Now, let’s assume you have more entries but can’t enter them right now for some reason. 

To postpone that batch until later, all you have to do is save your changes. Saving a batch 

is just like saving a record or a document.  

 

If you want to save the batch and work on another Performance Batch, you would simply 

use the Save option on the File menu or Tool Bar, and then create a new one or select 

another from the list. Let’s demonstrate actually leaving the batch process and coming 

back later.  

 

As with records and documents, Exit automatically saves your changes for you and closes 

the screen you are on. Let’s use the ‘X’ this time. 

4. Click the X in the upper right-hand corner of the screen to postpone the batch that you 

have created. 

 

The following message is displayed: 

Do you want to save the changes in process? 

If you said ‘No’ at this point, the entries would not be saved, but the batch would still 

exist and be empty. Let’s say ‘Yes’. 

5. Click Yes.  

 

The Performance Batch screen is closed. Now, let’s assume you are ready to keep 

working on that batch. 

6. On the Processing menu, select Performance Batch. 

 

The Performance Batch screen is displayed with your two batches in the Batch List area, 

in alphabetic order. My Batch should be highlighted and that batch’s entries displayed in 

the grid.  

 

Note: Administrator users will see postponed batches for all users, so batches can still be 

processed in a user’s absence. 

 

Recalling a postponed batch is as simple as selecting that batch in the list. 

7. Click on the My Postponed Batch entry. 

 

That batch’s entries are displayed in the grid below. You can now pick up where you left 

off. Easy as that. 
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8. Go ahead and post the batch.  

9. Exit the Document Viewer when the audit trail is displayed. 

 

This batch now has a Status of Posted like your other batch and is display only. Once a 

batch is posted and the audit trail printed, if needed, there really isn’t a need to keep that 

batch any longer. So, let’s delete these batches. 

10. On the File menu, select Delete Batch or on the Tool Bar, click the Delete Batch button 

to delete that batch. 

 

The following message is displayed: 

Delete the highlighted batch? 

11. Click Yes. 

 

That batch is deleted from the list and the remaining one is now selected and shown. 

12. Go ahead and delete the other batch. 

 

You delete any batch that you no longer want, whether that be a posted one or one in 

process that might have been in error. 

13. Close the Performance Batch screen. 

14. This concludes this tutorial and lesson. 
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This lesson covers how to use combo style batch processing screens and how to use advanced 

lookup features to rapidly populate batches. 

Tutorials 
Using a Combo Style Screen: demonstrates how a combo style batch screen differs from a 

grid style batch screen. 

Using Lookup to Load Batches: shows how to use the various features of the Lookup 

process to select records for use in batches. 

Using a Lookup Favorite to Load Batches: shows how to use a Lookup Favorite to select 

records for use in batches.  
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Tutorial 2.1 – Using a Combo Style Screen 

In the last lesson, we worked with a grid style batch processing screen. In this tutorial, we 

will use a combo style screen for batch processing. 

1. On the Processing menu, select Training Batch by Course.  

 

This batch option is used when a group of employees have attended the same course at 

the same time. For example, if a safety course or orientation course has been taught to a 

group of employees, you would use this option rather than the Training Batch by 

Employee option. 

 

In a combo style screen, you specify what happened once and then specify all of the 

employees for whom it happened. In the case of a training course, what happened was the 

completion of a specific course. 

 

Let’s start a new batch. 

2. On the File menu, select New Batch or on the Tool Bar, click the New Batch button to 

create a new batch. 

 

A new batch is created and added to the Batch List area. We won’t bother renaming it. 

3. In the Completion Date field, press F4.  

 

This should have put yesterday’s date in that field. This is because the Set Date Stamp 

step you took in the last lesson still holds true until you log out of People-Trak. The next 

time you log in, the date stamp will be set back to the current date. 

4. In the Course Code field, click the popup button. 

 

The Training Course table is displayed. 

5. Click Search and then select the CPR course.  

 

The remaining fields in the Course Details frame are completed from the table. These 

entries complete the course record for all of the employees who attended the course. Now 

we must enter those employees. 

6. Click in the Full Name column on the first row of the grid. 

 

You can enter full or partial names or employee numbers to select employees.  

7. Use this feature now to select three or four records. (Just use last names that start with B.) 

 

The batch is now ready to post.  

8. On the File menu, select Post Batch to start the posting process.  

 

As with the grid style screens, an audit trail is generated when posting is complete.   

9. Close the Document Viewer. 

 

The batch is shown as Posted. 
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10. Close the Training Batch by Course screen.  

11. Select one of the employees for whom you posted a training course and confirm that the 

posting was made. This same posting is made for each employee you selected. 

12. Close any open records. 

13. Continue with the next tutorial. 
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Tutorial 2.2 – Using Lookup to Load Batches 

You have now seen how to select records in both grid style and combo style batches. It is fast 

and easy. However, there are even more powerful methods of selecting employees. We’ll try 

this here. 

1. On the Processing menu, select Training Batch by Course.  

2. Create a new batch. 

3. In the Completion Date field, enter today’s date. 

4. In the Course Code field, use the popup to select the CPR course. 

5. On the File menu, select Lookup Group. 

 

When the Lookup screen is displayed, you can use any of the regular features associated 

with the Lookup screen to select an entire group of employees for processing. Let’s try a 

few options. 

6. Click on the Custom tab.  

 

Now let’s assume that you wanted to record a training course that was completed for 

every employee in a specific department. You could look up the employees individually, 

or you could enter a simple query and select them all at once.  

7. Enter the following:  

 

Field Name Department Code 

Operator = 

Contents 700 

8. Click Search to start the search. 

 

The employees working in department 700 (Technical Support) are listed.  

9. Click OK to return this list to the grid.  

10. Quickly review the grid.  

 

If one or more of the employees was not present in the course that day, simply use the 

Delete Row button to delete that employee from the list. Try it now.  

11. Delete Gilley.  

 

Likewise, if another employee from another department was present, you can simply 

select the employee directly.  

 

You can perform another Lookup Group and those results will be added to the end of the 

current batch. Let’s do just that. 

12. On the File menu, select Lookup Group. 
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13. Click on the Custom tab.  

 

Now let’s assume another department also attended the course.  

14. Enter the following:  

 

Field Name Department Code 

Operator = 

Contents 500 

15. Click Search to start the search. 

 

The employees working in department 500 (Training) are listed.  

16. Click OK to return this list to the grid. 

 

The employees from this second lookup are added to the end of the current batch. 

 

Note: If you wanted to replace the current batch with this second lookup, all you would 

have had to do is use the Delete Batch option on the File menu, create a new batch and do 

this new lookup. 

17. The list of employees now reflects the actual attendees in the course, so post the batch.  

 

An entry for the course specified will be added to the training history for each employee 

listed. You can verify this if you wish.  

18. Close the Document Viewer and the Training Batch by Course screen. 

 

Let’s show how the Lookup screen can be used with grid style batch screens. 

19. On the Processing menu, select Performance Batch. 

20. Create a new batch. 

21. On the File menu, select Lookup Group. 

22. Use the Lookup screen to select all employees.  

 

When the list of employees is returned to the grid, you have an automatic checklist of the 

employees who need to have information recorded. If the record is not complete, the 

batch is not complete. If you need to, you can save the batch and complete it at a later 

date.  

23. Delete this batch and the other ones you created earlier. 

24. Close the Performance Batch screen.  

25. Continue with the next tutorial. 

 

 

 



Lesson 2 

 

20     Batch Processing 
 

Tutorial 2.3 – Using a Lookup Favorite to Load Batches 

Favorites are queries that you create and save. A favorite is essentially a named query that 

you can recall when performing a lookup. You’ll learn more about favorites in a future 

lesson. For now, follow along.  

1. On the Documents menu, select Lookup Favorites.  

2. On the File menu, select New Lookup Favorite or on the Tool Bar, click the New 

Lookup Favorite button.  

 

A new lookup favorite is created, and the Lookup Favorites screen is displayed. 

3. In the Lookup Name field, enter Department 700. 

4. In the Explorer Category field, enter whatever category you desire, overriding the table 

if necessary. Leave the Category field set to User. 

5. On the Query tab, enter the following equation: 

 

Department Code = 700 

6. On the Tool Bar, click the Run Lookup Favorite button to test the query.  

 

The test is a report that uses the standard lookup fields. Each employee in the list will be 

from department 700 (Technical Support). 

7. Close the Document Viewer. 

8. Close the Lookup Favorites screen, saving the favorite.  

9. Close the Explorer. 

10. On the Processing menu, select Event Batch.  

11. Create a new batch. 

12. On the File menu, select Lookup Group.  

13. When the Lookup screen is displayed, click the Favorites tab. 

 

The list box on the Favorites tab shows all of the favorites that you have created. At the 

present time, you should see the favorite just created: Department 700.  

14. Click on Department 700 to select the favorite and then click Search to perform the 

query associated with the favorite.  

 

The list of records presented should match the test report run when the favorite was 

created. In the future, additional records may be present as records change and then 

match the criteria of the query. The query associated with a favorite is dynamic. The 

query equations are executed when the favorite is processed. 

15. Click OK to return the selected employees to the batch grid.  

 

In daily operations, favorites are an immense time saver. You can create favorites for 
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each of your commonly used queries such as departments, locations, etc. Then with just a 

quick click, you can populate an entire batch. 

16. Go ahead and delete this batch.  

17. Close the Event Batch screen.  

18. Exit People-Trak. 

19. This concludes this tutorial and lesson. 

 

 

 


